
This commit upgrades the Linux kernel to 6.12.18 from 6.6.x, which comes from the linux-yocto upstream. The following changes we made to support the kernel upgrade. For linux debian package deb_patches folder. We adapt the kernel related patch for 6.12.18, and cherry pick the following 8 commits to support to build the kernel 6.12.x. 1) commit f77deecbb5d4 "d/rules.real: Unset KBUILD_HOSTCFLAGS etc. instead of overriding to be empty" https://salsa.debian.org/kernel-team/linux/-/commit/f77deecbb5d4 2) commit 0d0d62b7d1cc "d/rules.d/Makefile.inc: Add scripts/include to header include path" https://salsa.debian.org/kernel-team/linux/-/commit/0d0d62b7d1cc 3) commit 4ad01663251d "[x86] linux-cpupower: Update turbostat Makefile to define BUILD_BUG_HEADER" https://salsa.debian.org/kernel-team/linux/-/commit/4ad01663251d 4) commit fced95b415be "hyperv-daemons: Update for upstream removal of hv_fcopy_daemon" https://salsa.debian.org/kernel-team/linux/-/commit/fced95b415be 5) commit 3a17dcbfe0be "d/rules.d/certs: Add newly required include directory to CPPFLAGS" https://salsa.debian.org/kernel-team/linux/-/commit/3a17dcbfe0be 6) commit 15b6859742d4 "Disable building rtla, since bullseye's libtraceevent and libtracefs are too old" https://salsa.debian.org/kernel-team/linux/-/commit/15b6859742d4 7) commit b4b93560d441 "[ia64] Drop all ia64 configs due to upstream dropping IA64 arch" https://salsa.debian.org/kernel-team/linux/-/commit/b4b93560d441 8) commit b93faa99519d "linux-kbuild: Add scripts/module-common.c (Closes: #1087495)" https://salsa.debian.org/kernel-team/linux/-/commit/b93faa99519d For the Linux source code patches folder. 1) We adapt the patch 0001, 0003, 0005, 0006, 0010, 0014 and 0017 based on kernel-6.12.18. 2) Remove all the ice port back patches because that has been included in our source code. For the kernel config. We enable CONFIG_CPUSETS_V1 and CONFIG_MEMCG_V1 to fix install issue. Verification: - Build kernel and out of tree modules success for rt and std. - Build iso success for rt and std. - Install success onto a All-in-One lab with rt kernel, and can switch to std kernel. - Boot up successfully in the lab. - The sanity testing was run and the test results PASS. - The cyclictest benchmark was also run on the starlingx lab, the result is "samples: 43199996 avg: 1656.295 std_dev: 67.617 max: 8827 99.9999th percentile: 8652“,It is worse than linux-6.6.x. - The network performance test had been done. For TCP, better than kernel-6.6.x, for UDP, a little worse than kernel-6.6.x, for STCP, can not do the test that is same with kernel-6.6.x. Story: 2011384 Task: 51856 Change-Id: I06ff2f3ab3620fe887f1e5e72ea9022a0cea6102 Signed-off-by: Jiping Ma <jiping.ma2@windriver.com>
79 lines
2.7 KiB
Diff
79 lines
2.7 KiB
Diff
From ca2a6b12ce2421e4e70705059b143e2f43c65efe Mon Sep 17 00:00:00 2001
|
|
From: Jiping Ma <jiping.ma2@windriver.com>
|
|
Date: Tue, 18 Mar 2025 07:24:15 +0000
|
|
Subject: [PATCH 16/16] tools: Fix the build errors
|
|
|
|
Add "{ }" in the code block of case to fix the following build error.
|
|
|
|
tools/power/x86/turbostat/turbostat.c:2811:4: error: a label can
|
|
only be part of a statement and a declaration is not a statement
|
|
2811 | const unsigned long value_raw = t->pmt_counter[i];
|
|
| ^~~~~
|
|
|
|
Signed-off-by: Jiping Ma <jiping.ma2@windriver.com>
|
|
---
|
|
tools/power/x86/turbostat/turbostat.c | 30 ++++++++++++++++-----------
|
|
1 file changed, 18 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/tools/power/x86/turbostat/turbostat.c b/tools/power/x86/turbostat/turbostat.c
|
|
index 235e82fe7d0a..9a3d38259042 100644
|
|
--- a/tools/power/x86/turbostat/turbostat.c
|
|
+++ b/tools/power/x86/turbostat/turbostat.c
|
|
@@ -2808,11 +2808,13 @@ int format_counters(struct thread_data *t, struct core_data *c, struct pkg_data
|
|
break;
|
|
|
|
case PMT_TYPE_XTAL_TIME:
|
|
- const unsigned long value_raw = t->pmt_counter[i];
|
|
- const double value_converted = 100.0 * value_raw / crystal_hz / interval_float;
|
|
+ {
|
|
+ const unsigned long value_raw = t->pmt_counter[i];
|
|
+ const double value_converted = 100.0 * value_raw / crystal_hz / interval_float;
|
|
|
|
- outp += sprintf(outp, "%s%.2f", (printed++ ? delim : ""), value_converted);
|
|
- break;
|
|
+ outp += sprintf(outp, "%s%.2f", (printed++ ? delim : ""), value_converted);
|
|
+ break;
|
|
+ }
|
|
}
|
|
}
|
|
|
|
@@ -2889,11 +2891,13 @@ int format_counters(struct thread_data *t, struct core_data *c, struct pkg_data
|
|
break;
|
|
|
|
case PMT_TYPE_XTAL_TIME:
|
|
- const unsigned long value_raw = c->pmt_counter[i];
|
|
- const double value_converted = 100.0 * value_raw / crystal_hz / interval_float;
|
|
+ {
|
|
+ const unsigned long value_raw = c->pmt_counter[i];
|
|
+ const double value_converted = 100.0 * value_raw / crystal_hz / interval_float;
|
|
|
|
- outp += sprintf(outp, "%s%.2f", (printed++ ? delim : ""), value_converted);
|
|
- break;
|
|
+ outp += sprintf(outp, "%s%.2f", (printed++ ? delim : ""), value_converted);
|
|
+ break;
|
|
+ }
|
|
}
|
|
}
|
|
|
|
@@ -3088,11 +3092,13 @@ int format_counters(struct thread_data *t, struct core_data *c, struct pkg_data
|
|
break;
|
|
|
|
case PMT_TYPE_XTAL_TIME:
|
|
- const unsigned long value_raw = p->pmt_counter[i];
|
|
- const double value_converted = 100.0 * value_raw / crystal_hz / interval_float;
|
|
+ {
|
|
+ const unsigned long value_raw = p->pmt_counter[i];
|
|
+ const double value_converted = 100.0 * value_raw / crystal_hz / interval_float;
|
|
|
|
- outp += sprintf(outp, "%s%.2f", (printed++ ? delim : ""), value_converted);
|
|
- break;
|
|
+ outp += sprintf(outp, "%s%.2f", (printed++ ? delim : ""), value_converted);
|
|
+ break;
|
|
+ }
|
|
}
|
|
}
|
|
|
|
--
|
|
2.47.1
|
|
|